Asterisk & openVPN

Dieses Thema im Forum "Technik-Smalltalk" wurde erstellt von OMethfessel, 29. April 2009.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. OMethfessel

    OMethfessel Eingetragener Provider

    Registriert seit:
    21. Januar 2006
    Beiträge:
    2.021
    Ort:
    Wiesbaden, Rhein-Main-Gebiet
    Firmenname:
    Methfessel Computers
    Anbieterprofil:
    Klick
    Guten Morgen,

    ich nutze aktuell einen Asterisk Server im Büro 1 für Telefonie. Über openVPN sind die LANs von Büro 1 und Büro 2 verbunden.

    Das läuft alles super, die Performance ist gut und NFS etc. läuft stabil. Nur Asterisk macht Probleme. In Büro2 habe ich ein VoiP Telefon, welches bis gestern stabil lief. Nach einem restart beider Server kann ich mit dem Telefon jedoch keinerlei Verbindung zum Asterisk Server herstellen.

    Die Konfiguration wurde nicht geändert. Lediglich die openVPN Strecke wurde neu initialisiert. Hat jemand Erfahrung mit dieser Konfiguration und kann mir eventuell Tipps geben, was ich besonders dabei beachten muss?

    Danke

    Gruß

    Oliver
     
  2. chilltier

    chilltier Guest

    AW: Asterisk & openVPN

    Zunächst: TUN oder TAP im OpenVPN Tunnel?

    Normalerweise gibt es da nichts zu beachten. Es muss keine Bridge sein. Ein Gerouteter Tunnel reicht vollkommen.
    Ärger gibt es regelmäßig bei/mit der MTU Konfiguration und der Paketfragmentation, was um paar Ecken mit den VoIP-Codec´s kollidieren kann.

    Die MTU lieber auf 1400 runter drehen oder noch weniger wäre mein erster Versuch.
     
  3. OMethfessel

    OMethfessel Eingetragener Provider

    Registriert seit:
    21. Januar 2006
    Beiträge:
    2.021
    Ort:
    Wiesbaden, Rhein-Main-Gebiet
    Firmenname:
    Methfessel Computers
    Anbieterprofil:
    Klick
    AW: Asterisk & openVPN

    MTU hat nichts gebracht... Danke für den Tipp.

    Es handelt sich um ein TAP Device
     
  4. mgross

    mgross New Member

    Registriert seit:
    21. November 2003
    Beiträge:
    35
    AW: Asterisk & openVPN

    Läuft Openvpn auf dem Router oder hinter einem NAT?
     
  5. chilltier

    chilltier Guest

    AW: Asterisk & openVPN

    Hm. TAP verhält sich dann ziemlich transparent. Es ist ja dann eine Layer2 Bridge, die Du via OpenVPN laufen hast. Als nächstes würde ich erstmal testen, ob sich die Geräte überhaupt sehen und ob die MAC-Adressen auf der jeweils anderen Seite wirklich auftauchen.

    Irgendwas filtert aktiv. Was, ist noch die Frage.
     
  6. jodost

    jodost Eingetragener Provider

    Registriert seit:
    23. März 2004
    Beiträge:
    779
    Firmenname:
    D&T Internet GmbH
    Anbieterprofil:
    Klick
    AW: Asterisk & openVPN

    Tipps leider nicht, aber schneide doch mal mit tcpdump/ngrep/... auf Port 5060 UDP an beiden Standorten mit, was das Telefon und der Asterisk miteinander an Daten austauschen?

    Viele Grüße,

    Joern
     
  7. OMethfessel

    OMethfessel Eingetragener Provider

    Registriert seit:
    21. Januar 2006
    Beiträge:
    2.021
    Ort:
    Wiesbaden, Rhein-Main-Gebiet
    Firmenname:
    Methfessel Computers
    Anbieterprofil:
    Klick
    AW: Asterisk & openVPN

    Danke für die Tipps.

    Ich hab das Problem zwischenzeitlich lösen können. Es war ganz doof eine falsche iptables Regel. Dummweise hat das System beim Starten eine Port-Forwarding Regel eingetragen:
    Code:
    iptables -t nat -A PREROUTING -p udp --dport 5060 -j DNAT --to-destination XX.XX.XX.XX
    
    XX.XX.XX.XX ist die IP des VoIP Telefons am Standort B. Und damit wurde der UDP Traffic Port 5060 vom Telefon an sich selbst forwarded..... Doof gelaufen.

    Hab die Regel nun rausgenommen und es läuft wieder.
     
  8. chilltier

    chilltier Guest

    AW: Asterisk & openVPN

    Sag ich doch... "Irgendwas filtert aktiv. Was, ist noch die Frage."

    :)
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen