IP-Adresse mit 0 am Ende ein Problem?

Dieses Thema im Forum "Technik-Smalltalk" wurde erstellt von alex.p, 8. April 2012.

  1. special-host.de

    special-host.de Eingetragener Provider

    Registriert seit:
    20. Juli 2005
    Beiträge:
    38
    Firmenname:
    Special-Host
    Anbieterprofil:
    Klick
    AW: IP-Adresse mit 0 am Ende ein Problem?

    Hi,

    0 am Ende ist möglich, aber nicht bei einem /24'er Subnetz da bei diesem Subnetz die 0 die Netzadresse ist.

    z.B. das Subnetz 192.168.200.0/24

    Netzadresse: 192.168.200.0
    Erste IP-Adresse: 192.168.200.1
    Letzte IP-adresse: 192.168.200.254
    Broadcast Adresse: 192.168.200.255
     
  2. ibex.p

    ibex.p Guest

    AW: IP-Adresse mit 0 am Ende ein Problem?

    Frage an die Community:
    Realisiert jemand seinen Internet-Zugang über Telekom-DSL mit Router Sinus 154 DSL Basic 3 ... um den Test auf die Internetseite hvv.de einmal durchzuführen?
     
  3. smartTERRA GmbH Falk

    smartTERRA GmbH Falk Eingetragener Provider

    Registriert seit:
    23. Dezember 2000
    Beiträge:
    4.240
    Ort:
    Düsseldorf
    Firmenname:
    smartTERRA GmbH
    Anbieterprofil:
    Klick
    AW: IP-Adresse mit 0 am Ende ein Problem?

    Hallo,

    Cliff hat natürlich vollkommen Unrecht mit seiner Aussage, mache Dich doch mal bitte mit IP Subnetting und der CIDR Schreibweise vertraut.

    Allerdings verwendet der Hoster der Domain eine zumindest äußerst unübliche Subnetierung, denn:

    Code:
    falks-mba:~ falk$ host hvv.de
    hvv.de has address 87.253.164.0
    Die Webseite hat also die IP-Adresse 87.253.164.0.

    Code:
    falks-mba:~ falk$ whois 87.253.164.0
    ...
    inetnum:         87.253.164.0 - 87.253.164.7
    Dem Kunden, der die Server für die o.g. Domain betreibt, wurde der o.g. IP-Adressbereich zugewiesen. Mir ist es bis heute nur so unter gekommen, dass für den Kunden ein Subnetz angelegt wird. In diesem Falle also 87.253.164.0/29. Hier ist die .0 aber die Netz- und die .7 die Broadcast-Adresse. Der nutzbare IP-Bereich beschränkt sich also auf die .1 bis .6, wozu aber die definitiv in Nutzung befindliche .0 nicht passt.

    Ab hier kann man nur spekulieren: betreibt der Provider mehrere Kunden in einem großem Subnetz, so dass sich diese eine Layer2 Domäne teilen und nur ein Default-GW haben? Oder wird hier intern mit PtP Verbindungen gearbeitet, so dass das komplette IP-Netz inkl. Netz- und Broadcast-Adresse nutzbar ist?

    Wie dem auch sei, ich vermute hier eher das Problem bei älterem Routing-Equipment beim Besucher der Seite, welches aus dem Tritt kommt, wenn eine Domain auf eine vermeintliche Netzadresse verweist.

    Schönen Gruß aus Düsseldorf,


    Falk Brockerhoff
     
  4. heutger

    heutger Eingetragener Provider

    Registriert seit:
    9. Oktober 2004
    Beiträge:
    235
    Ort:
    Fulda
    Firmenname:
    PSW GROUP
    Anbieterprofil:
    Klick
    AW: IP-Adresse mit 0 am Ende ein Problem?

    Ja, sehe ich auch so, merkwürdige Konfiguration, aber an sich obliegt das ja dem Provider. Insoweit sollte aber auch mit dem älteren Router und Einsatz eines Proxies, Webproxies, VPN-Zugangs o. Ä. das Problem auch aus der Welt zu schaffen sein. Der eigentliche Provider ist mit seinem Setup glücklich und wird dies wohl nicht ändern wollen, nach deren Aussagen seien auch solche Probleme wohl nicht weiter bekannt.

    Mit freundlichen Grüßen,
    Christian Heutger
     
  5. Mr. Brain

    Mr. Brain Erfahrener Benutzer

    Registriert seit:
    13. Mai 2005
    Beiträge:
    2.289
    Ort:
    Frankfurt am Main
    Firmenname:
    Welcome 2 Inter.Net
    Anbieterprofil:
    Klick
    AW: IP-Adresse mit 0 am Ende ein Problem?

    Wie kommst du auf die Annahme, dass es sich um ein /29 handelt und du Netz- und Broadcast-Adresse festlegst? Der Eintrag im whois kann ein Netzsegment sein, welches auf einen Kunden bei der RIPE eingetragen wurde. Somit wären alle IPs (.0 bis .7) in dem Netz auch nutzbar.
     
  6. smartTERRA GmbH Falk

    smartTERRA GmbH Falk Eingetragener Provider

    Registriert seit:
    23. Dezember 2000
    Beiträge:
    4.240
    Ort:
    Düsseldorf
    Firmenname:
    smartTERRA GmbH
    Anbieterprofil:
    Klick
    AW: IP-Adresse mit 0 am Ende ein Problem?

    Weil ich es für unüblich halte alle Kundennetze in einem großem Layer 2 Segment zu betreiben. So etwas mag zwar durchaus anzutreffen sein, zeugt aber nicht von ordentlichem Netzdesign.

    Hier komme ich also entweder nur durch Subnetierung oder mit einer PtP Verbindung weiter. Bei letzterer kann ich natürlich auch die .0 und .7 verwenden, aber dieses Setup empfinde ich persönlich nicht als das Mittel der Wahl. Dies kann aber natürlich auch persönliche Vorliebe sein. Ich vermute aber, dass letzteres hier zum Einsatz kommt.

    Schönen Gruß aus Düsseldorf,


    Falk Brockerhoff
     

Diese Seite empfehlen