PHP update problem

Dieses Thema im Forum "Webserver (Software): Linux, Unix, etc." wurde erstellt von P-A-S, 2. Juli 2005.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. P-A-S

    P-A-S New Member

    Registriert seit:
    25. Januar 2004
    Beiträge:
    74
    Hallo, ich will php 3.4.3 auf 3.4.11 upadten hab mir folgende rpm`s geladen:

    wget ftp://ftp.suse.com/pub/projects/apache/php4/9.1-i386/apache2-mod_php4-4.3.11-0.1.i586.rpm
    wget ftp://ftp.suse.com/pub/projects/apache/php4/9.1-i386/php4-4.3.11-0.1.i586.rpm
    wget ftp://ftp.suse.com/pub/projects/apache/php4/9.1-i386/php4-ctype-4.3.11-0.1.i586.rpm
    wget ftp://ftp.suse.com/pub/projects/apache/php4/9.1-i386/php4-curl-4.3.11-0.1.i586.rpm
    wget ftp://ftp.suse.com/pub/projects/apache/php4/9.1-i386/php4-devel-4.3.11-0.1.i586.rpm
    wget ftp://ftp.suse.com/pub/projects/apache/php4/9.1-i386/php4-domxml-4.3.11-0.1.i586.rpm
    wget ftp://ftp.suse.com/pub/projects/apache/php4/9.1-i386/php4-gd-4.3.11-0.1.i586.rpm
    wget ftp://ftp.suse.com/pub/projects/apache/php4/9.1-i386/php4-gettext-4.3.11-0.1.i586.rpm
    wget ftp://ftp.suse.com/pub/projects/apache/php4/9.1-i386/php4-iconv-4.3.11-0.1.i586.rpm
    wget ftp://ftp.suse.com/pub/projects/apache/php4/9.1-i386/php4-imap-4.3.11-0.1.i586.rpm
    wget ftp://ftp.suse.com/pub/projects/apache/php4/9.1-i386/php4-mysql-4.3.11-0.1.i586.rpm
    wget ftp://ftp.suse.com/pub/projects/apache/php4/9.1-i386/php4-session-4.3.11-0.1.i586.rpm
    wget ftp://ftp.suse.com/pub/projects/apache/php4/9.1-i386/php4-sockets-4.3.11-0.1.i586.rpm
    wget ftp://ftp.suse.com/pub/projects/apache/php4/9.1-i386/php4-xslt-4.3.11-0.1.i586.rpm
    wget ftp://ftp.suse.com/pub/projects/apache/php4/9.1-i386/php4-zlib-4.3.11-0.1.i586.rpm

    nur bei installieren der rpm kommt

    warning: apache2-mod_php4-4.3.11-0.1.i586.rpm: V3 DSA signature: NOKEY, key ID efb694ea
    error: Failed dependencies:
    php4 = 4.3.11 is needed by apache2-mod_php4-4.3.11-0.1

    und

    warning: php4-4.3.11-0.1.i586.rpm: V3 DSA signature: NOKEY, key ID efb694ea
    error: Failed dependencies:
    php4 = 4.3.4 is needed by (installed) php4-gettext-4.3.4-26
    php4 = 4.3.4 is needed by (installed) php4-bcmath-4.3.4-26
    php4 = 4.3.4 is needed by (installed) php4-bz2-4.3.4-26
    php4 = 4.3.4 is needed by (installed) php4-calendar-4.3.4-26
    php4 = 4.3.4 is needed by (installed) php4-ctype-4.3.4-26
    php4 = 4.3.4 is needed by (installed) php4-curl-4.3.4-26
    php4 = 4.3.4 is needed by (installed) php4-dba-4.3.4-26
    php4 = 4.3.4 is needed by (installed) php4-dbase-4.3.4-26
    php4 = 4.3.4 is needed by (installed) php4-domxml-4.3.4-26
    php4 = 4.3.4 is needed by (installed) php4-filepro-4.3.4-26
    php4 = 4.3.4 is needed by (installed) php4-ftp-4.3.4-26
    php4 = 4.3.4 is needed by (installed) php4-iconv-4.3.4-26
    php4 = 4.3.4 is needed by (installed) php4-ldap-4.3.4-26
    php4 = 4.3.4 is needed by (installed) php4-mbstring-4.3.4-26
    php4 = 4.3.4 is needed by (installed) php4-mime_magic-4.3.4-26
    php4 = 4.3.4 is needed by (installed) php4-pgsql-4.3.4-26
    php4 = 4.3.4 is needed by (installed) php4-readline-4.3.4-26
    php4 = 4.3.4 is needed by (installed) php4-gd-4.3.4-26
    php4 = 4.3.4 is needed by (installed) php4-gmp-4.3.4-26
    php4 = 4.3.4 is needed by (installed) php4-mcal-4.3.4-26
    php4 = 4.3.4 is needed by (installed) php4-mcrypt-4.3.4-26
    php4 = 4.3.4 is needed by (installed) php4-mhash-4.3.4-26
    php4 = 4.3.4 is needed by (installed) php4-qtdom-4.3.4-26
    php4 = 4.3.4 is needed by (installed) php4-shmop-4.3.4-26
    php4 = 4.3.4 is needed by (installed) php4-snmp-4.3.4-26
    php4 = 4.3.4 is needed by (installed) php4-sockets-4.3.4-26
    php4 = 4.3.4 is needed by (installed) php4-swf-4.3.4-26
    php4 = 4.3.4 is needed by (installed) php4-sysvsem-4.3.4-26
    php4 = 4.3.4 is needed by (installed) php4-unixODBC-4.3.4-26
    php4 = 4.3.4 is needed by (installed) php4-xslt-4.3.4-26
    php4 = 4.3.4 is needed by (installed) php4-yp-4.3.4-26
    php4 = 4.3.4 is needed by (installed) php4-zlib-4.3.4-26
    php4 = 4.3.4 is needed by (installed) php4-pear-4.3.4-26
    php4 = 4.3.4 is needed by (installed) apache2-mod_php4-4.3.4-43.31
    php4 = 4.3.4 is needed by (installed) mod_php4-core-4.3.4-43.31
    php4 = 4.3.4 is needed by (installed) php4-exif-4.3.4-43.31
    php4 = 4.3.4 is needed by (installed) php4-imap-4.3.4-43.31
    php4 = 4.3.4 is needed by (installed) php4-mysql-4.3.4-43.31
    php4 = 4.3.4 is needed by (installed) php4-recode-4.3.4-43.31
    php4 = 4.3.4 is needed by (installed) php4-servlet-4.3.4-43.31
    php4 = 4.3.4 is needed by (installed) php4-session-4.3.4-43.31
    php4 = 4.3.4 is needed by (installed) php4-sysvshm-4.3.4-43.31
    php4 = 4.3.4 is needed by (installed) php4-wddx-4.3.4-43.31


    soll ich alle alten deinstallieren oder was soll ich machen?

    thx!
     
  2. abra-x-as

    abra-x-as Guest

    Generell kannst du wenn du SuSE nutzt das Online Update verwenden.

    <offtopic>
    Bist du dir sicher das du weißt was du da tust?
    </offtopic>
     
  3. MMG-Media

    MMG-Media Eingetragener Provider

    Registriert seit:
    12. Februar 2003
    Beiträge:
    453
    Ort:
    Bremen
    Firmenname:
    MMG-Media Internet S...
    Anbieterprofil:
    Klick
    Mit welchem Befehl installierst/updatest du denn?

    rpm -i oder rpm -U?

    versuch mal ein

    rpm -Uhv --test *.rpm

    das führt ein Testlauf durch. Ist dieser ok kannst du das Update mit rpm -Uhv *.rpm durchführen.
     
  4. alber

    alber New Member

    Registriert seit:
    16. Juni 2000
    Beiträge:
    8.894
    So wie ich ihm vorhin verstanden hatte ist er nach dieser Anleitung gegangen ;)
     
  5. P-A-S

    P-A-S New Member

    Registriert seit:
    25. Januar 2004
    Beiträge:
    74
    hat sich erledigt, THX!
     
  6. xtended

    xtended New Member

    Registriert seit:
    4. April 2005
    Beiträge:
    6
    Ich habe das selbe Problem...
    Was ist nun die Lösung gewesen???

    gruß

    xtended
     
  7. alber

    alber New Member

    Registriert seit:
    16. Juni 2000
    Beiträge:
    8.894
    Ganz einfach. Du darfst keine unterschiedlich gängigen Version z.b von PHP4 und mpd_php4 rauf knallen. Update entweder PHP über Yast bzw apt-get oder installiere und compiliere es von Hand.
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen