Probleme mit Startseite in httpdocs

Dieses Thema im Forum "Webserver (Software): Windows" wurde erstellt von Patattack, 22. Februar 2005.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Patattack

    Patattack New Member

    Registriert seit:
    2. Dezember 2004
    Beiträge:
    63
    Hallo,

    http://qdaniel.de/

    leitet auf die index.html obwohl diese
    1. nicht vorhanden ist
    2. eine index.php vorhanden ist:

    http://www.cws-server11.de/datei.jpg

    ich versteh das nicht ganz? Das Problem war plötzlich vorhanden.

    Über eure Hilfe wäre ich sehr sehr dankbar.

    viele Grüße
    Patrick
     
  2. Soulkeeper

    Soulkeeper New Member

    Registriert seit:
    28. Mai 2001
    Beiträge:
    636
    Ort:
    Castrop-Rauxel
    Ich verstehe Deine Frage nicht ganz. Aber als Tipp: Schau doch mal, welche Startdokumente Du eingetragen hast.

    Viele Grüße,

    Nils
     
  3. alber

    alber New Member

    Registriert seit:
    16. Juni 2000
    Beiträge:
    8.894
    schau mal in der http.conf ob die index.html
    mit drinne ist wenn nicht kannste sie nachtragen
     
  4. Tom-i

    Tom-i Eingetragener Provider

    Registriert seit:
    7. Oktober 2004
    Beiträge:
    1.759
    Ort:
    Menden
    Firmenname:
    Serverman
    Anbieterprofil:
    Klick
    ...

    zur not kannnst du auch eine .htaccess mit inhalt

    DirectoryIndex index.php

    in den ordner legen, dann sollte er die auch erkennen.

    ansonsten index.php in der httpd.conf unter DirectoryIndex hinzufügen.
     
  5. jts-online

    jts-online Eingetragener Provider

    Registriert seit:
    16. Juni 2004
    Beiträge:
    222
    Ort:
    Dillingen/Saar
    Firmenname:
    easyISP UG
    Anbieterprofil:
    Klick
    Das sieht für mich eher wie ein Rewrite bzw Redirect aus!

    was macht denn deine index.php?

    bzw. ist in der Serverkonfig etwas eingetragen, was die Umleitung veranlassen könnte ?
     
  6. Patattack

    Patattack New Member

    Registriert seit:
    2. Dezember 2004
    Beiträge:
    63
    #
    # DirectoryIndex: sets the file that Apache will serve if a directory
    # is requested.
    #
    # The index.html.var file (a type-map) is used to deliver content-
    # negotiated documents. The MultiViews Option can be used for the
    # same purpose, but it is much slower.
    #
    DirectoryIndex index.html index.php index.php3 index.htm

    in der http.conf stimmt alles. Bei anderen Kunden auf den gleichen Server funktioniert ja der Zugriff auf die index.php nur bei diesen komischerweise nicht.

    bzw. ist in der Serverkonfig etwas eingetragen, was die Umleitung veranlassen könnte ?
    Habe dort nichts umgestellt. Wie gesagt, bei den anderen User funktioniert es tadelos. :) echt komisch.

    zur not kannnst du auch eine .htaccess mit inhalt

    DirectoryIndex index.php

    werd ich versuchen, ob ich damit erfolg habe.

    Danke für eure Hilfe.
     
  7. Tom-i

    Tom-i Eingetragener Provider

    Registriert seit:
    7. Oktober 2004
    Beiträge:
    1.759
    Ort:
    Menden
    Firmenname:
    Serverman
    Anbieterprofil:
    Klick
    ...

    kleine bescheidene frage wo ich das nochmal reflektiere:

    rcapache2 restart

    hast du aber brav gemacht nachdem die einträge gemacht wurden (zumindest die in der httpd.conf)?
     
  8. Patattack

    Patattack New Member

    Registriert seit:
    2. Dezember 2004
    Beiträge:
    63
    der Eintrag war schon enthalten mit index.php
    Ich habe garnichts geändert. :)

    Ich hab aber auch schon den Server rebootet aber leider ohne Erfolg.

    Das ist echt komisch? Ein Buk von Plesk?

    Grüße
    Patrick
     
  9. Patattack

    Patattack New Member

    Registriert seit:
    2. Dezember 2004
    Beiträge:
    63
    Habe das Problem lösen können.

    Danke aber trotzdem für eure Antworten.
     
  10. kaem

    kaem New Member

    Registriert seit:
    7. August 2005
    Beiträge:
    7
    Ort:
    Oberpfalz/Bayern
    Wie war die Lösung?

    ich habe gleiches Problem?

    Plesk 7.5.3. ,IIS
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen