Squid auf Hosteurope Windows-VS - mangelnde Geschwindigkeit

Dieses Thema im Forum "Webserver (Software): Windows" wurde erstellt von chrissi_la, 1. Januar 2009.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. chrissi_la

    chrissi_la New Member

    Registriert seit:
    1. Januar 2009
    Beiträge:
    3
    Hallo,

    ich habe bei Hosteurope einen virtuellen Windowsserver gemietet, da ich sonst nur auf FreeBSD setze und mich mit Linux nicht anfreunden kann.

    Der Server ist ein Virtual Server Windows L 3.0 mit 512 MB RAM, auf diesem läuft Squid in der Version 2.7 STABLE5. Ziel war es eigentlich, das Laden von Webinhalten zu beschleunigen. Nun brachte es allerdings den gegenteiligen Effekt. An physikalischem Speicher sind lt. Windows-Taskmanager noch 211000 kB verfügbar.

    Von einem DSL-Anschluss habe ich ohne Proxyserver bis zu 350 kBit/s beim Download von Dateien. Mit Proxy reduziert sich die Geschwindigkeit auf knapp 200 kBit/s, auch bei Dateien, die im Cache liegen und mit einem TCP_HIT im Logfile auftauchen.

    Jetzt stellt sich mir also die Frage, an was diese Geschwindigkeitseinbußen liegen könnten. Evtl. hat hier ja jemand ähnliche Erfahrungen gemacht. Bevor ich es in meiner Verzweiflung mit einem Upgrade probiere, ist es doch günstiger, diese Frage hier einmal zu stellen. :)

    Solltet Ihr noch weitere Informationen benötigen, stelle ich sie Euch gern zur Verfügung.


    Mit besten Grüßen-

    Christian
     
  2. jpfote

    jpfote Erfahrener Benutzer

    Registriert seit:
    25. Juni 2005
    Beiträge:
    967
    AW: Squid auf Hosteurope Windows-VS - mangelnde Geschwindigkeit

    Also wenn Du Dich noch ein paar Tage gedulden kannst: Ich habe am Dienstag einen virt. Linux-Server bestellt (den kleinen). Sobald der blöde Aktivierungsbrief da ist, kann ich mal fix squid installieren und testen, wie schnell meiner dann ist. Aber dauert halt noch etwas, bis der Brief ankommt :).

    Grüße Jens
     
  3. chrissi_la

    chrissi_la New Member

    Registriert seit:
    1. Januar 2009
    Beiträge:
    3
    AW: Squid auf Hosteurope Windows-VS - mangelnde Geschwindigkeit

    Hallo Jens,

    danke für Deine Antwort. Natürlich kann ich mich ein bisschen gedulden. :) Es wäre nett, wenn Du das mal testen könntest und Deine Erfahrungen hier postest.

    Der Squid ist übrigens an Port 80 gebunden. Das macht sich enorm bemerkbar, greife ich über o2 mobil auf den Proxy zu. Vorher war er an Port 88 gebunden, was zu einer Geschwindigkeit von knappen 25 kBit/s führte.


    Christian
     
  4. DjGL

    DjGL Eingetragener Provider

    Registriert seit:
    28. November 2005
    Beiträge:
    1.085
    Ort:
    Wien
    Firmenname:
    Light-Gap.net
    Anbieterprofil:
    Klick
    AW: Squid auf Hosteurope Windows-VS - mangelnde Geschwindigkeit

    Ist auf dem Windows Server auch ein Webserver drauf?
    Leg da mal ne Testfile rein und lad Sie dir ohne Proxy runter.
    Wenn Du da auch nur 200kbit/s zusammenbekommst liegts wohl an der Shared Internetverbindung des vServers oder das Wirtsystem ist Schuld.
     
  5. chrissi_la

    chrissi_la New Member

    Registriert seit:
    1. Januar 2009
    Beiträge:
    3
    AW: Squid auf Hosteurope Windows-VS - mangelnde Geschwindigkeit

    Hallo Günter,

    nein, einen Webserver habe ich auf dem vServer nicht laufen; jedoch einen FTP-Server (Serv-U), mit welchem ich Downloadraten bis zu 350 kBit/s erziele.

    Das ist es ja, was mich stutzig macht. Meinen Verdacht, dass der Zugriff auf die virtuelle Festplatte der Flaschenhals ist, hat dieses Resultat widerlegt.

    Leider habe ich momentan keine weitere Idee, woran es noch liegen könnte.


    MbG
    Christian
     
  6. DjGL

    DjGL Eingetragener Provider

    Registriert seit:
    28. November 2005
    Beiträge:
    1.085
    Ort:
    Wien
    Firmenname:
    Light-Gap.net
    Anbieterprofil:
    Klick
    AW: Squid auf Hosteurope Windows-VS - mangelnde Geschwindigkeit

    Schonmal testweise einen anderen Proxy probiert zB einfach mal nen Apache mit mod_proxy oder von mir aus auch FreeProxy?
     
  7. A-N

    A-N Erfahrener Benutzer

    Registriert seit:
    13. September 2004
    Beiträge:
    1.669
    AW: Squid auf Hosteurope Windows-VS - mangelnde Geschwindigkeit

    Resourcen Fresser Apache? Squid lief bei einem vServer mit 64 MB Arbeitsspeicher 1A. Muss wohl an Windows liegen :)
     
  8. DjGL

    DjGL Eingetragener Provider

    Registriert seit:
    28. November 2005
    Beiträge:
    1.085
    Ort:
    Wien
    Firmenname:
    Light-Gap.net
    Anbieterprofil:
    Klick
    AW: Squid auf Hosteurope Windows-VS - mangelnde Geschwindigkeit

    =>
    ------------------------------------------------------------------------

    Oder ganz einfach daran das Squid einfach nicht für Windows programmiert wurde?
    An allem kann man Windows nicht die Schuld geben und dass Windows selbst mehr als 200kbit/s rausbringt sollte klar sein.
     
    Zuletzt bearbeitet: 8. Januar 2009
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen