stabile PHP Version

Dieses Thema im Forum "Script Serverseitig" wurde erstellt von cyberfreddy, 16. Juli 2014.

  1. cyberfreddy

    cyberfreddy Erfahrener Benutzer

    Registriert seit:
    7. Februar 2001
    Beiträge:
    590
    Hallo in die Runde!

    Bei einem sehr großen Hostinganbieter habe ich eben vom Support mitgeteilt bekommen, dass auf den shared Webspaces "in absehbarer Zeit" kein PHP 5.4 zur Verfügung stehen wird ... angeblich weil diese noch nicht ausreichend als stabil gilt.
    Hmm. Die 5.3er, die dort läuft, wird nur noch kurz mit Sicherheitsupdates versorgt (lt. Wikipedia).
    Ich bin verwirrt.
    Was meint der Mann? Könnt ihr mir das erklären?

    Gruß
    Nils
     
  2. discountnetz-hosting

    discountnetz-hosting Eingetragener Provider

    Registriert seit:
    24. Mai 2011
    Beiträge:
    34
    Ort:
    Lohsa
    Firmenname:
    Discountnetz Hosting
    Anbieterprofil:
    Klick
    AW: stabile PHP Version

    Hallo Nils,
    mich würde interessieren welcher große Hosting Anbieter das ist. PHP 5.4 ist nun wirklich Standard, einige Hoster bieten 5.3, 5.4 und 5.5 wahlweise an um eine gewisse Flexibilität zu gewährleisten.

    Ich kann die Aussage deines Hosters das 5.4 nicht stabil läuft jedenfalls nicht nachvollziehen.

    Freundliche Grüsse
    Jan Hannuschka
     
  3. antondollmaier

    antondollmaier Eingetragener Provider

    Registriert seit:
    19. April 2004
    Beiträge:
    902
    Firmenname:
    ADIT Systems
    Anbieterprofil:
    Klick
    AW: stabile PHP Version

    Die Interpretation von "stabil" ist durchaus ... variabel.

    PHP selbst sieht 5.4 durchaus als "stable" an, eher schon in Richtung "veraltet".

    Es kommt also wohl noch drauf an, wie die Maintainer der Linux/*BSD-Distributionen dies sehen.

    Bei Debian gibt es 5.4 erst seit Mai 2013 mit Debian 7.0 "Wheezy". Bei CentOS/Redhat/Fedora sieht das hingegen anders aus - Redhat hat 5.4 im Enterprise noch gar nicht dabei.

    Angesichts der Tatsache, dass einige CMS mindestens PHP 5.4 erfordern (Joomla 3.3, Typo3 4.7, Drupal8), halte ich es persönlich für mindestens fragwürdig, wenn an so veralteten Versionen festgehalten wird.

    Dies insbesondere unter dem Aspekt, dass es - selbst mit Confixx - möglich ist, zusätzlich zur Standard-PHP-Installation des Betriebssystems noch andere manuell gebaute Versionen zur Verfügung zu stellen.
     
  4. RichBone

    RichBone Geprüfter Provider

    Registriert seit:
    7. August 2006
    Beiträge:
    2.155
    Ort:
    Eisenhüttenstadt
    Firmenname:
    RB Media Group GmbH
    Anbieterprofil:
    Klick
    AW: stabile PHP Version

    Hallo

    evtl. setzt sein Provider Confixx ein, was nicht sorichtig mit PHP 5.4 und höher zusammen arbeiten möchte.

    Mit freundlichen Grüßen

    Martin Krüger
     
  5. [netcup] Felix

    [netcup] Felix Eingetragener Provider

    Registriert seit:
    13. Juni 2005
    Beiträge:
    4.871
    Ort:
    Karlsruhe
    Firmenname:
    netcup.de
    Anbieterprofil:
    Klick
    AW: stabile PHP Version

    Wobei man in Confixx durchaus mehrere PHP-Versionen parallel betreiben kann.

    Zwischen PHP 5.3 und 5.4 unterscheiden sich viele Webapplikationen. Schlecht supportete (aber leider sehr viele) schmeißen bei PHP 5.4 warnings, wenn diese nicht unterdrückt werden. Manche Webapplikationen sind wiederum nicht abwärtskompatibel.
     
  6. cyberfreddy

    cyberfreddy Erfahrener Benutzer

    Registriert seit:
    7. Februar 2001
    Beiträge:
    590
    AW: stabile PHP Version

    Vielen Dank für Eure Antworten/Kommentare!

    Mir ist es ja ebenfalls deshalb als nervig aufgefallen, weil ich nicht auf die aktuelle Version von "Moodle" updaten konnte.
    Da der Hoster folgenden Links selbst in seinen FAQs hat, ist die genaue Info kein Genheimnis:
    http://www.hosteurope-infos.de/phpinfo.php
    Keine Ahnung ob das auf Redhat Enterprise basiert...

    Aber ich kenne es eben auch von anderen Hostern so, dass ich entweder per .htaccess oder über das Controlpanel die Version anpassen kann. Das geht hier aber beides nicht.

    Ich wundere mich immer noch.

    Gruß
    Nils

    p.s.: Ach ja, Confixx läuft da nicht.
     

Diese Seite empfehlen