ZendOptimizer Problem

Dieses Thema im Forum "Script Serverseitig" wurde erstellt von timyboy, 5. August 2014.

  1. timyboy

    timyboy New Member

    Registriert seit:
    9. Januar 2008
    Beiträge:
    23
    Ich habe eine Auktionshaussoftware von PHPPROBID glaube 6.4 installiert. Auf dem Vserver ist Zend für PHP 5.3 installiert, was auch darauf läuft.
    Wenn ich nun die Webseite aufrufe, kommt folgender Fehler:
    Fatal error: Incompatible file format: The encoded file has format major ID 1, whereas the Loader expects 4 in /var/www/webX/html/includes/init.php on line 0

    Ein Update der Software ist nicht möglich...!

    Wer kann hierbei helfen?
     
  2. darkstar

    darkstar Erfahrener Benutzer

    Registriert seit:
    24. Januar 2001
    Beiträge:
    1.105
    AW: ZendOptimizer Problem

    Aha, noch jemand, der mit der PHP-Update-Falle kämpft.

    Zur Ursache:
    Dein Script ist so verschlüsselt, dass es nur mit einer älteren Version von Zend Guard Loader funktioniert. Diese funktioniert wohl nur mit PHP 5.2.

    Lösung:
    A) korrekt: Für PHP 5.3 verschlüsselte Version beim Hersteller anfordern (was praktisch eigentlich kein Update wäre), eventuell müssen aber trotzdem Änderungen erfolgen (was dann doch ein Update wäre).
    B) alternativ kurzfristig: Downgrade auf PHP 5.2 (ggf. Neuinstallation vserver, wenn Du nicht mit backports arbeiten willst)
    langfristig: Wechsel der Auktionsplattform

    MfG
    darkstar
     
  3. timyboy

    timyboy New Member

    Registriert seit:
    9. Januar 2008
    Beiträge:
    23
    AW: ZendOptimizer Problem

    Kann man auf einem Vserver für ein einzelnes Web PHP 5.2 installieren oder geht dies wenn dann nur für den gesamten Server?
     

Diese Seite empfehlen